[MinnowBoard] problem with 0.94 firmware for Minnowboard Max

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[MinnowBoard] problem with 0.94 firmware for Minnowboard Max

zahra rahimkhani
Hello,
I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


Best regards,
Zahra


_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
Reply | Threaded
Open this post in threaded view
|

Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

Minnow Ware

Hi Zahra,

 

try that one: https://github.com/MinnowWare/UDK2018-MinnowBoard.

 

It starts Windows!

 

It is based on UDK2018 and firmware 1.0 and is created on a Windows PC, installed like that one:

https://github.com/MinnowWare/HowTo-setup-an-UEFI-Development-PC

 

Why you are using the old FW?

That old FW is not available on the Intel MinnowBoard site anymore!

https://firmware.intel.com/projects/minnowboard-max

 

 

Regards,

Kilian

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Saturday, April 6, 2019 6:36:45 AM
To: MinnowBoard Development and Community Discussion
Subject: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max
 
Hello,
I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


Best regards,
Zahra


_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
Reply | Threaded
Open this post in threaded view
|

Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

zahra rahimkhani
Thank you for your reply .
I need Intel  I210/I211 network driver. I used version 0.98 and it shows this message.

Do you think that should change it ?


On Sat, Apr 6, 2019 at 11:00 AM Minnow Ware <[hidden email]> wrote:

Hi Zahra,

 

try that one: https://github.com/MinnowWare/UDK2018-MinnowBoard.

 

It starts Windows!

 

It is based on UDK2018 and firmware 1.0 and is created on a Windows PC, installed like that one:

https://github.com/MinnowWare/HowTo-setup-an-UEFI-Development-PC

 

Why you are using the old FW?

That old FW is not available on the Intel MinnowBoard site anymore!

https://firmware.intel.com/projects/minnowboard-max

 

 

Regards,

Kilian

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Saturday, April 6, 2019 6:36:45 AM
To: MinnowBoard Development and Community Discussion
Subject: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max
 
Hello,
I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


Best regards,
Zahra

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
Reply | Threaded
Open this post in threaded view
|

Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

zahra rahimkhani

I downloaded  this document
and used  this part
HOW TO BUILD (LINUX ENVIRONMENT)
  and compiled it on my system. could you help me how I can solve this error on output of file .bin ?

The message on file bin spi flash was this

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


I find this BoardGpios.c on source .but i dont know how solve it ?

Best regards ,
Zahra



On Sat, Apr 6, 2019 at 11:13 AM zahra rahimkhani <[hidden email]> wrote:
Thank you for your reply .
I need Intel  I210/I211 network driver. I used version 0.98 and it shows this message.

Do you think that should change it ?


On Sat, Apr 6, 2019 at 11:00 AM Minnow Ware <[hidden email]> wrote:

Hi Zahra,

 

try that one: https://github.com/MinnowWare/UDK2018-MinnowBoard.

 

It starts Windows!

 

It is based on UDK2018 and firmware 1.0 and is created on a Windows PC, installed like that one:

https://github.com/MinnowWare/HowTo-setup-an-UEFI-Development-PC

 

Why you are using the old FW?

That old FW is not available on the Intel MinnowBoard site anymore!

https://firmware.intel.com/projects/minnowboard-max

 

 

Regards,

Kilian

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Saturday, April 6, 2019 6:36:45 AM
To: MinnowBoard Development and Community Discussion
Subject: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max
 
Hello,
I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


Best regards,
Zahra

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
Reply | Threaded
Open this post in threaded view
|

Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

Minnow Ware

Hi Zarah,

 

just remove that lines from the source code.

 

Looks to me that the board variant is identified there, by checking

how pins are strapped with resistors, but I don’t have your sourcecode.

 

Use my tool to get familiar with Baytrail GPIO’s.

 

https://github.com/MinnowWare/Visual-HWTools-for-UEFI-Shell/tree/master/x64/Efi64\BYTGPIOSpy.efi

 

Don’t use the old sourcecode!

 

Regards,

Kilian

 

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Monday, April 8, 2019 11:12:03 AM
To: MinnowBoard Community Email List
Subject: Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max
 

I downloaded  this document
and used  this part
HOW TO BUILD (LINUX ENVIRONMENT)
  and compiled it on my system. could you help me how I can solve this error on output of file .bin ?

The message on file bin spi flash was this

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


I find this BoardGpios.c on source .but i dont know how solve it ?

Best regards ,
Zahra



On Sat, Apr 6, 2019 at 11:13 AM zahra rahimkhani <[hidden email]> wrote:
Thank you for your reply .
I need Intel  I210/I211 network driver. I used version 0.98 and it shows this message.

Do you think that should change it ?


On Sat, Apr 6, 2019 at 11:00 AM Minnow Ware <[hidden email]> wrote:

Hi Zahra,

 

try that one: https://github.com/MinnowWare/UDK2018-MinnowBoard.

 

It starts Windows!

 

It is based on UDK2018 and firmware 1.0 and is created on a Windows PC, installed like that one:

https://github.com/MinnowWare/HowTo-setup-an-UEFI-Development-PC

 

Why you are using the old FW?

That old FW is not available on the Intel MinnowBoard site anymore!

https://firmware.intel.com/projects/minnowboard-max

 

 

Regards,

Kilian

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Saturday, April 6, 2019 6:36:45 AM
To: MinnowBoard Development and Community Discussion
Subject: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max
 
Hello,
I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)


Best regards,
Zahra

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard
Reply | Threaded
Open this post in threaded view
|

Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

Richardson, Brian

Older releases of MinnowBoard Max/Turbot firmware are available on an archive page: https://firmware.intel.com/content/minnowboard-maxturbot-release-archives

 

If you have UEFI development questions for MinnowBoard, I recommend trying the EDK II developer list on groups.io. This is a more active discussion list. https://edk2.groups.io/g/devel

 

Thanks … br

---

Brian Richardson -- Director of Firmware Ecosystem Engagements

[hidden email] -- @intel_brian

Firmware Ecosystem & Business Development, Firmware Integration & Development (FID)

https://software.intel.com/en-us/meet-the-developers/evangelists/team/brian-richardson

 

From: elinux-MinnowBoard <[hidden email]> On Behalf Of Minnow Ware
Sent: Monday, April 8, 2019 5:28 AM
To: MinnowBoard Community Email List <[hidden email]>
Subject: Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

 

Hi Zarah,

 

just remove that lines from the source code.

 

Looks to me that the board variant is identified there, by checking

how pins are strapped with resistors, but I don’t have your sourcecode.

 

Use my tool to get familiar with Baytrail GPIO’s.

 

https://github.com/MinnowWare/Visual-HWTools-for-UEFI-Shell/tree/master/x64/Efi64\BYTGPIOSpy.efi

 

Don’t use the old sourcecode!

 

Regards,

Kilian

 

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Monday, April 8, 2019 11:12:03 AM
To: MinnowBoard Community Email List
Subject: Re: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

 

 

I downloaded  this document

and used  this part

HOW TO BUILD (LINUX ENVIRONMENT)

  and compiled it on my system. could you help me how I can solve this error on output of file .bin ?

 

The message on file bin spi flash was this

 

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)

 

 

I find this BoardGpios.c on source .but i dont know how solve it ?

 

Best regards ,

Zahra

 

 

 

On Sat, Apr 6, 2019 at 11:13 AM zahra rahimkhani <[hidden email]> wrote:

Thank you for your reply .

I need Intel  I210/I211 network driver. I used version 0.98 and it shows this message.

 

Do you think that should change it ?

 

 

On Sat, Apr 6, 2019 at 11:00 AM Minnow Ware <[hidden email]> wrote:

Hi Zahra,

 

try that one: https://github.com/MinnowWare/UDK2018-MinnowBoard.

 

It starts Windows!

 

It is based on UDK2018 and firmware 1.0 and is created on a Windows PC, installed like that one:

https://github.com/MinnowWare/HowTo-setup-an-UEFI-Development-PC

 

Why you are using the old FW?

That old FW is not available on the Intel MinnowBoard site anymore!

https://firmware.intel.com/projects/minnowboard-max

 

 

Regards,

Kilian

 


From: elinux-MinnowBoard <[hidden email]> on behalf of zahra rahimkhani <[hidden email]>
Sent: Saturday, April 6, 2019 6:36:45 AM
To: MinnowBoard Development and Community Discussion
Subject: [MinnowBoard] problem with 0.94 firmware for Minnowboard Max

 

Hello,

I am trying to use   Debug 0.94 Firmware on Minnowboard Max. I use the SPI programmer  to do the initial programming. it shows the follow message.

 

MmioConf0[0xFED0E200], MmioPadval[0xFED0E208]
Gpio_S5_4 value is 0x3
Gpio_S5_17 value is 0x2
MultiPlatformGpioTableInit()...

ASSERT_EFI_ERROR (Status = Not Found)
ASSERT m:\Vlv2TbltDevicePkg\Library\MultiPlatformLib\BoardGpios\BoardGpios.c(185): !EFI_ERROR (Status)

 

 

Best regards,

Zahra

 

_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard


_______________________________________________
elinux-MinnowBoard mailing list
[hidden email]
http://lists.elinux.org/mailman/listinfo/elinux-minnowboard